Thursday, June 15, 2006

Hope you enjoyed the pictures...

as the camera has to go back.

What a piece of junk. I'm not thrilled with how this camera has worked from the beginning: to have it break within 6 months of purchase, the length of time it took them to fix it. Then to send it back with a different problem. They replaced the optical unit, but somehow managed to mangle the on/off button.

When it came back and I tried to turn it on, it wouldn't work, but I assumed the batteries were dead. I changed batteries and messed around with it a bit, and it did eventually turn on.

Today it won't turn on at all-and those batteries are obviously brand new. Looking at the on/off button, I can tell it's wonky.

So dear Canan, this might be a DOA as far as I'm concerned.

Sadly, Matt chose this camera due to it's high customer reviews. However, I wouldn't give this camera any kind of positive reviews.

So my day isn't starting on a good foot. As not only am I having the camera issues, I was showing Matt the increases on the Landscape shawl this morning and I found two errors. Errors that are going to have to be fixed. That's a lot of knitting to undo and I'm not happy about it.

Okay, that's it, I'm casting on something new.

3 Comments:

At 11:23 AM , Acornbud said...

What a bummer. Sounds like the camera is a lemon. Oh boy! A new project;)

 
At 11:36 PM , Tori said...

Wow How FRUSTRATING! Well at least it graced you and us with a wonderful picture of Gena. Hope you get a good one and some extras after all this!

 
At 8:05 AM , Cindy said...

Well, it seems that the camera is fine... I just have to be a little careful how I set the batteries and the on/off is a little wonky... but it works. Good enough for me!

 

Post a Comment

Links to this post:

Create a Link

<< Home